volumes

docker compose volumes Один путь только для контейнера, без двоеточия и пути на хостовой машине

Предположим, что в docker-compose у нас синтаксис вроде:

volumes:
  - ./host/path:/container/path
  - /worker/node_modules

-- во втором случае (без двоеточия) указан т.н. анонимный том (см. anonymous volumes)

docker ERROR: for web Cannot start service web: OCI runtime create failed: Ошибка (bind file directory)

Проблема возникает, если вы пытаетесь примонтировать файл к папке (можно только файл к файлу или папку к папке), проверьте:

  1. свой docker-compose.yml
  2. файлы и папке на локальном диске (действительно ли это то, что вы подразумеваете)

вот такое должно работать нормально:

Subscribe to RSS - volumes